Overcast

GIS System Requirements  

As of October 1, 2003 there is one version of the web site available. Please use this page to get to this site so that you will be notified of any changes in status. If you have any questions you may call the GIS Help Desk at 250-6860.

New version: Internet GIS Property Information System (ArcIMS 9.1)
Site Requirements:

PC - Netscape 7.1 or IE 5.0 or higher

Mac - IE 5.0 or higher

Because of inherent limitations in our third-party web development software, the Buncombe County GIS web site may have some limitations for browsers running on the MacIntosh platform or Netscape on the Intel platform. The viewing of the property record card is not possible under Netscape at this time. This situation is under investigation.